Solaris package management 2
Solaris notes
cksum for checksuming stuff since md5 of shasum is not installed by default..
pkg and rpm useful commands
Thanks for reading :)
cksum for checksuming stuff since md5 of shasum is not installed by default..
pkg and rpm useful commands
pkg | rpm | function |
---|---|---|
pkgadd -d 'pkg' | rpm -ivh 'rpm' | install |
pkgrm 'pkg' | rpm -e 'rpm' | uninstall |
pkginfo | rpm -qa | list all |
pkginfo -l 'pkg' | rpm -i 'rpm' | info |
pkgchk-l -p 'file' | rpm -qf 'file' | package of file |
grep 'file' /var/sadm/install/contents | same as above | |
pkgchk -l 'pkg' | rpm -ql 'rpm' | list installed package contents |
pkgchk -l -d 'pkg' | rpm -qlp 'rpm' | list uninstalled package contents |
pkgchk 'pkg' | rpm -V 'rpm' | verify package contents |
Thanks for reading :)